Sitecore Commerce 9.1 Initial Release Installation Error - Cannot bind argument to parameter 'SXAModuleFullPath' because it is null








Are you following the below post and getting the error called: 'SXAModuleFullPath' because it is null



https://buoctrenmay.com/2019/04/18/sitecore-commerce-9-1-initial-release-step-by-step-install-guide-on-your-machine/




No worries –

  • Go to the PowerShell scripts
  • Go to the variables called 

SXACommerceModuleFullPath,SXAStorefrontModuleFullPath,SXAStorefrontThemeModuleFullPath, SXAStorefrontCatalogModuleFullPath

And change the value to provide the full path with file name(your file directory) instead of * as below:

SXACommerceModuleFullPath = Resolve-Path -Path "C:\Ashish\Sitecore\Software\sc910_com_install\Sitecore Commerce Experience Accelerator 2.0.181.zip"

SXAStorefrontModuleFullPath = Resolve-Path -Path "C:\Ashish\Sitecore\Software\sc910_com_install\Sitecore Commerce Experience Accelerator Storefront 2.0.181.zip"

SXAStorefrontThemeModuleFullPath = Resolve-Path -Path "C:\Ashish\Sitecore\Software\sc910_com_install\Sitecore Commerce Experience Accelerator Storefront Themes 2.0.181.zip"

SXAStorefrontCatalogModuleFullPath = Resolve-Path -Path "C:\Ashish\Sitecore\Software\sc910_com_install\Sitecore Commerce Experience Accelerator Habitat Catalog*.zip"



              
Hope this will solve your issue.

Happy Sitecoring and Commerce.







Comments

Post a Comment

Popular posts from this blog

Where is the Log File in #Sitecore 9?

SETTING UP YOUR FIRST SITECORE HELIX APPLICATION FROM SCRATCH (BLANK SOLUTION)

Different way to unpublish the item in sitecore